Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2024-1538

File Manager <= 7.2.4 - Cross-Site Request Forgery to Local JS File Inclusion

Description

The File Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 7.2.4. This is due to missing or incorrect nonce validation on the wp_file_manager page that includes files through the 'lang' parameter. This makes it possible for unauthenticated attackers to include local JavaScript files that can be leveraged to achieve RCE via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This issue was partially patched in version 7.2.4, and fully patched in 7.2.5.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

mndpsingh287 File Manager

Default version status: unaffected

  • 0 to ≤ 7.2.4affected

References