Skip to content
CVE PROGRAM SOURCE RECORD7.2 High

CVE-2024-13509

WS Form LITE and PRO <= 1.10.13 - Unauthenticated Stored Cross-Site Scripting

Description

The WS Form LITE and PRO plugins for WordPress are vulnerable to Stored Cross-Site Scripting via the url parameter in all versions up to, and including, 1.10.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability is partially fixed in 1.10.13 and completely fixed in 1.10.14.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

westguard WS Form LITE – Drag & Drop Contact Form Builder

Default version status: unaffected

  • 0 to ≤ 1.10.13affected

WS Form WS Form Pro

Default version status: unaffected

  • 0 to ≤ 1.10.13affected

References