Skip to content
CVE PROGRAM SOURCE RECORD2.4 Low

CVE-2024-10719

Stored Cross-site Scripting (XSS) in phpipam/phpipam

Description

A stored cross-site scripting (XSS) vulnerability exists in phpipam version 1.5.2, specifically in the circuits options functionality. This vulnerability allows an attacker to inject malicious scripts via the 'option' parameter in the POST request to /phpipam/app/admin/circuits/edit-options-submit.php. The injected script can be executed in the context of the user's browser, leading to potential cookie theft and end-user file disclosure. The issue is fixed in version 1.7.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

phpipam phpipam/phpipam

  • unspecified to < 1.7.0affected

References