Skip to content
CVE PROGRAM SOURCE RECORD7.7 High

CVE-2023-49734

Apache Superset: Privilege Escalation Vulnerability

Description

An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Superset

Default version status: unaffected

  • 0 to < 2.1.2affected
  • 3.0.0 to < 3.0.2affected

References