Skip to content
CVE PROGRAM SOURCE RECORD7.9 High

CVE-2023-49145

Apache NiFi: Improper Neutralization of Input in Advanced User Interface for Jolt

Description

Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache NiFi

Default version status: unaffected

  • 0.7.0 to ≤ 1.23.2affected

References