Skip to content
CVE PROGRAM SOURCE RECORD3.4 Low

CVE-2023-47121

Discourse SSRF vulnerability in Embedding

Description

Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the embedding feature is susceptible to server side request forgery. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable the Embedding feature.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • < 3.1.3affected
  • >= 3.2.0.beta0, < 3.2.0.beta3affected

References