Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2023-46801

Apache Linkis DataSource: DataSource Remote code execution vulnerability

Description

In Apache Linkis <= 1.5.0, data source management module, when adding Mysql data source, exists remote code execution vulnerability for java version < 1.8.0_241. The deserialization vulnerability exploited through jrmp can inject malicious files into the server and execute them. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out.  We recommend that users upgrade the java version to >= 1.8.0_241. Or users upgrade Linkis to version 1.6.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Linkis DataSource

Default version status: unaffected

  • 1.4.0 to < 1.6.0affected

References