Description
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache ActiveMQ
Default version status: unaffected
5.18.0 to < 5.18.3affected5.17.0 to < 5.17.6affected5.16.0 to < 5.16.7affected0 to < 5.15.16affected
Apache Software Foundation Apache ActiveMQ Legacy OpenWire Module
Default version status: unaffected
5.18.0 to < 5.18.3affected5.17.0 to < 5.17.6affected5.16.0 to < 5.16.7affected5.8.0 to < 5.15.16affected
References
- https://activemq.apache.org/security-advisories.data/CVE-2023-46604-announcement.txt ↗
- https://www.openwall.com/lists/oss-security/2023/10/27/5 ↗
- https://security.netapp.com/advisory/ntap-20231110-0010/ ↗
- https://packetstormsecurity.com/files/175676/Apache-ActiveMQ-Unauthenticated-Remote-Code-Execution.html ↗
- https://lists.debian.org/debian-lts-announce/2023/11/msg00013.html ↗
- http://seclists.org/fulldisclosure/2024/Apr/18 ↗
- https://lists.debian.org/debian-lts-announce/2024/10/msg00027.html ↗
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-46604 ↗