Description
Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has been patched in version 3.3.17, 4.1.3, 5.3.4, 6.1.0.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
grails grails-core
>= 6.0.0, < 6.1.0affected>= 5.0.0, < 5.3.4affected>= 4.0.0, < 4.1.3affected>= 2.0.0, < 3.3.17affected
References
- https://github.com/grails/grails-core/security/advisories/GHSA-3pjv-r7w4-2cf5 ↗
- https://github.com/grails/grails-core/issues/13302 ↗
- https://github.com/grails/grails-core/commit/74326bdd2cf7dcb594092165e9464520f8366c60 ↗
- https://github.com/grails/grails-core/commit/c401faaa6c24c021c758b95f72304a0e855a8db3 ↗
- https://grails.org/blog/2023-12-20-cve-data-binding-dos.html ↗