Description
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially crafted, invalid trailer header could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache Tomcat
Default version status: unaffected
11.0.0-M1 to ≤ 11.0.0-M11affected10.1.0-M1 to ≤ 10.1.13affected9.0.0-M1 to ≤ 9.0.81affected8.5.0 to ≤ 8.5.93affected3 to < 8.5.0unknown10.0.0-M1 to ≤ 10.0.27unknown
References
- https://lists.apache.org/thread/2pv8yz1pyp088tsxfb7ogltk9msk0jdp ↗
- http://www.openwall.com/lists/oss-security/2023/10/10/10 ↗
- https://www.debian.org/security/2023/dsa-5522 ↗
- https://www.debian.org/security/2023/dsa-5521 ↗
- https://lists.debian.org/debian-lts-announce/2023/10/msg00020.html ↗
- https://security.netapp.com/advisory/ntap-20231103-0007/ ↗