Skip to content
CVE PROGRAM SOURCE RECORD7.0 High

CVE-2023-4504

OpenPrinting CUPS/libppd Postscript Parsing Heap Overflow

Description

Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

OpenPrinting CUPS

Default version status: unaffected

  • 0 to < 2.4.6affected

OpenPrinting libppd

Default version status: unaffected

  • 0 to < d09348baffected

References