Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2023-43826

Apache Guacamole: Integer overflow in handling of VNC image buffers

Description

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Guacamole

Default version status: unaffected

  • 0 to ≤ 1.5.3affected

References