Description
Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that allow an attacker to store on database and then load on JSPs or Angular templates. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
The OpenNMS Group Horizon
Default version status: unaffected
31.0.8 to < 32.0.2affected0 to < 31.0.8unknown
The OpenNMS Group Meridian
Default version status: unaffected
2020.0.0 to ≤ 2020.1.37affected2021.0.0 to ≤ 2021.1.29affected2022.0.0 to ≤ 2022.1.18affected2023.0.0 to ≤ 2023.1.5affected