Skip to content
CVE PROGRAM SOURCE RECORD5.5 Medium

CVE-2023-40032

Potential segfault due to NULL pointer dereference in libvips

Description

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

libvips libvips

  • < 8.14.4affected

References