Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2023-38684

Discourse vulnerable to ossible DDoS due to unbounded limits in various controller actions

Description

Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, in multiple controller actions, Discourse accepts limit params but does not impose any upper bound on the values being accepted. Without an upper bound, the software may allow arbitrary users to generate DB queries which may end up exhausting the resources on the server. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. There are no known workarounds for this vulnerability.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • >= 3.1.0.beta1, < 3.1.0.beta7affected
  • < 3.0.6affected

References