Description
Cross-site scripting (XSS) vulnerability in the edit Service Access Policy page in Liferay Portal 7.0.0 through 7.4.3.87, and Liferay DXP 7.4 GA through update 87, 7.3 GA through update 29, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into a service access policy's `Service Class` text field.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Liferay Portal
Default version status: unaffected
7.0.0 to ≤ 7.4.3.87affected
Liferay DXP
Default version status: unaffected
7.0.10 to ≤ de-102affected7.1.10 to ≤ dxp-28affected7.2.10 to ≤ dxp-20affected7.3.10 to ≤ 7.3.10-u29affected7.4.13 to ≤ 7.4.13-u87affected