Skip to content
CVE PROGRAM SOURCE RECORD4.3 Medium

CVE-2023-37906

Discourse vulnerable to DoS via post edit reason

Description

Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, a malicious user can edit a post in a topic and cause a DoS with a carefully crafted edit reason. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. There are no known workarounds for this vulnerability.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • >= 3.1.0.beta1, < 3.1.0.beta7affected
  • < 3.0.6affected

References