Skip to content
CVE PROGRAM SOURCE RECORD7.1 High

CVE-2023-28447

Cross site scripting vulnerability in Javascript escaping in smarty/smarty

Description

Smarty is a template engine for PHP. In affected versions smarty did not properly escape javascript code. An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. Users are advised to upgrade to either version 3.1.48 or to 4.3.1 to resolve this issue. There are no known workarounds for this vulnerability.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

smarty-php smarty

  • >= 4.0.0, < 4.3.1affected
  • < 3.1.48affected

References