Skip to content
CVE PROGRAM SOURCE RECORD4.5 Medium

CVE-2023-28107

Discourse vulnerable to multisite DoS by spamming backups

Description

Discourse is an open-source discussion platform. Prior to version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches, a user logged as an administrator can request backups multiple times, which will eat up all the connections to the DB. If this is done on a site using multisite, then it can affect the whole cluster. The vulnerability is patched in version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • stable < 3.0.2affected
  • beta < 3.1.0.beta3affected
  • tests-passed < 3.1.0.beta3affected

References