Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2023-27597

OpenSIPS has vulnerability in the parse_uri() function

Description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

OpenSIPS opensips

  • < 3.1.8affected
  • >= 3.2.0, < 3.2.5affected

References