Skip to content
CVE PROGRAM SOURCE RECORD4.4 Medium

CVE-2023-25172

Discourse vulnerable to Cross-site Scripting - user name displayed on post

Description

Discourse is an open-source discussion platform. Prior to version 3.0.1 of the `stable` branch and version 3.1.0.beta2 of the `beta` and `tests-passed` branches, a maliciously crafted URL can be included in a user's full name field to to carry out cross-site scripting attacks on sites with a disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. The vulnerability is patched in version 3.0.1 of the `stable` branch and version 3.1.0.beta2 of the `beta` and `tests-passed` branches. As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • stable < 3.0.1affected
  • beta < 3.1.0.beta2affected
  • tests-passed < 3.1.0.beta2affected

References