Skip to content
CVE PROGRAM SOURCE RECORD7.7 High

CVE-2023-23761

Improper authentication vulnerability in GitHub Enterprise Server leading to modification of secret gists

Description

An improper authentication vulnerability was identified in GitHub Enterprise Server that allowed an unauthorized actor to modify other users' secret gists by authenticating through an SSH certificate authority. To do so, a user had to know the secret gist's URL. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

GitHub Enterprise Server

Default version status: affected

  • 3.4.0 to ≤ 3.4.17affected
  • 3.5.0 to ≤ 3.5.14affected
  • 3.6.0 to ≤ 3.6.10affected
  • 3.7.0 to ≤ 3.7.7affected
  • 3.8.0 to < 3.8.1affected
  • 3.9.0unaffected

References