Skip to content
CVE PROGRAM SOURCE RECORD9.8 Critical

CVE-2023-22727

Database Query::offset() and limit() vulnerable to SQL injection in cakephp

Description

CakePHP is a development framework for PHP web apps. In affected versions the `Cake\Database\Query::limit()` and `Cake\Database\Query::offset()` methods are vulnerable to SQL injection if passed un-sanitized user request data. This issue has been fixed in 4.2.12, 4.3.11, 4.4.10. Users are advised to upgrade. Users unable to upgrade may mitigate this issue by using CakePHP's Pagination library. Manually validating or casting parameters to these methods will also mitigate the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

cakephp cakephp

  • >= 4.2.0, < 4.2.12affected
  • >= 4.3.0, < 4.3.11affected
  • >= 4.4.0, < 4.4.10affected

References