Skip to content
CVE PROGRAM SOURCE RECORD8.2 High

CVE-2023-0872

ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users

Description

The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

The OpenNMS Group Horizon

Default version status: unaffected

  • 31.0.8 to < 32.0.2affected
  • 0 to < 31.0.8unknown

The OpenNMS Group Meridian

Default version status: unaffected

  • 2020.0.0 to ≤ 2020.1.37affected
  • 2021.0.0 to ≤ 2021.1.29affected
  • 2022.0.0 to ≤ 2022.1.18affected
  • 2023.0.0 to ≤ 2023.1.5affected

References