Description
Multiple stored and reflected cross-site scripting vulnerabilities in webapp jsp pages in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to confidential session information. Users should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
The OpenNMS Group Meridian
Default version status: unaffected
2020.1.0 to < 2020.1.32affected2021.1.0 to < 2021.1.24affected2022.1.0 to < 2022.1.13affected2023.1.0unaffected
The OpenNMS Group Horizon
Default version status: affected
26.0.0 to < 31.0.4affected