Skip to content
CVE PROGRAM SOURCE RECORD3.5 Low

CVE-2022-4957

librespeed speedtest stats.php cross site scripting

Description

A vulnerability was found in librespeed speedtest up to 5.2.4. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file results/stats.php. The manipulation of the argument id leads to cross site scripting. The attack can be launched remotely. Upgrading to version 5.2.5 is able to address this issue. The patch is named a85f2c086f3449dffa8fe2edb5e2ef3ee72dc0e9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-246643.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

librespeed speedtest

  • 5.2.0affected
  • 5.2.1affected
  • 5.2.2affected
  • 5.2.3affected
  • 5.2.4affected

References