Description
An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a repository-scoped token with read/write access to modify Action Workflow files without a Workflow scope. The Create or Update file contents API should enforce workflow scope. This vulnerability affected all versions of GitHub Enterprise Server prior to version 3.7 and was fixed in versions 3.3.16, 3.4.11, 3.5.8, and 3.6.4. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
GitHub GitHub Enterprise Server
3.3 to < 3.3.16affected3.4 to < 3.4.11affected3.5 to < 3.5.8affected3.6 to < 3.6.4affected
References
- https://docs.github.com/en/enterprise-server%403.3/admin/release-notes#3.3.16 ↗
- https://docs.github.com/en/enterprise-server%403.4/admin/release-notes#3.4.11 ↗
- https://docs.github.com/en/enterprise-server%403.5/admin/release-notes#3.5.8 ↗
- https://docs.github.com/en/enterprise-server%403.6/admin/release-notes#3.6.4 ↗