Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2022-43766

Apache IoTDB prior to 0.13.3 allows DoS

Description

Apache IoTDB version 0.12.2 to 0.12.6, 0.13.0 to 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. Users should upgrade to 0.13.3 which addresses this issue or use a later version of Java to avoid it.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache IoTDB

  • unspecified to ≤ 0.13.2affected
  • 0.12.2 to < unspecifiedaffected

References