Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2022-41957

muhammara vulnerable to Unchecked Return Value to NULL Pointer Dereference

Description

Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

julianhille MuhammaraJS

  • < 2.6.2affected
  • >= 3.0.0, < 3.4.0affected

References