Skip to content
CVE PROGRAM SOURCE RECORD8.2 High

CVE-2022-41905

wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled

Description

WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

mar10 wsgidav

  • >= 3.0.0a1, < 4.1.0affected

References