Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2022-41704

Apache Batik prior to 1.16 allows RCE when loading untrusted SVG input

Description

A vulnerability in Batik of Apache XML Graphics allows an attacker to run untrusted Java code from an SVG. This issue affects Apache XML Graphics prior to 1.16. It is recommended to update to version 1.16.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache XML Graphics

  • Batik to ≤ 1.15affected

References