Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2022-39944

The Apache Linkis JDBC EngineConn module has a RCE Vulnerability

Description

In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Linkis

  • Apache Linkis to ≤ 1.2.0affected

References