Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2022-39315

Kirby CMS vulnerable to user enumeration in the brute force protection

Description

Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

getkirby kirby

  • < 3.5.8.2affected
  • >= 3.6.0, < 3.6.6.2affected
  • >= 3.7.0, < 3.7.5.1affected
  • = 3.8.0affected

References