Skip to content
CVE PROGRAM SOURCE RECORD5.1 Medium

CVE-2022-3474

Bazel leaks user credentials through the remote assets API

Description

A bad credential handling in the remote assets API for Bazel versions prior to 5.3.2 and 4.2.3 sends all user-provided credentials instead of only the required ones for the requests. We recommend upgrading to versions later than or equal to 5.3.2 or 4.2.3.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Google LLC Bazel

Default version status: unaffected

  • 5.0.0 to < 5.3.2affected
  • 4.0.0 to < 4.2.3affected
  • 3.0.0 to < 3.7.2affected

References