Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2022-31157

Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library

Description

LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

packbackbooks lti-1-3-php-library

  • < 5.0affected

References