Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2022-31121

Improper Input Validation in fabric hyperledger

Description

Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commit 0f1835949 which checks for missing consensus messages and returns an error to the consensus client should the message be missing. Users are advised to upgrade to versions 2.2.7 or v2.4.5. There are no known workarounds for this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

hyperledger fabric

  • < 2.2.7affected
  • >= 2.3.0, < 2.4.5affected

References