Skip to content
CVE PROGRAM SOURCE RECORD6.9 Medium

CVE-2022-31037

OroCommerce vulnerable to Cross-site Scripting via Shipping rule editing page

Description

OroCommerce is an open-source Business to Business Commerce application. Versions between 4.1.0 and 4.1.17 inclusive, 4.2.0 and 4.2.11 inclusive, and between 5.0.0 and 5.0.3 inclusive, are vulnerable to Cross-site Scripting in the UPS Surcharge field of the Shipping rule edit page. The attacker needs permission to create or edit a shipping rule. This issue has been patched in version 5.0.6. There are no known workarounds.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

oroinc orocommerce

  • >= 4.1.0, <= 4.1.17affected
  • >= 4.2.0, <= 4.2.11 affected
  • >= 5.0.0, <= 5.0.3affected

References