Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2022-29221

PHP Code Injection by malicious block or filename in Smarty

Description

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.45 and 4.1.1, template authors could inject php code by choosing a malicious {block} name or {include} file name. Sites that cannot fully trust template authors should upgrade to versions 3.1.45 or 4.1.1 to receive a patch for this issue. There are currently no known workarounds.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

smarty-php smarty

  • < 3.1.45affected
  • >= 4.0.0, < 4.1.1affected

References