Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2022-24879

Malfunction of Cross-Site Request Forgery token validation

Description

Shopware is an open source e-commerce software platform. Versions prior to 5.7.9 are vulnerable to malfunction of cross-site request forgery (CSRF) token validation. Under certain circumstances, the CSRF tokens were not generated anew and not validated correctly. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

shopware shopware

  • >= 5.2.0, < 5.7.9affected

References