Skip to content
CVE PROGRAM SOURCE RECORD6.1 Medium

CVE-2022-24858

Default redirect callback vulnerable to open redirects

Description

next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

nextauthjs next-auth

  • < 3.29.2, < 4.3.2affected

References