Skip to content
CVE PROGRAM SOURCE RECORD7.0 High

CVE-2022-24834

Heap overflow issue with the Lua cjson library used by Redis

Description

Redis is an in-memory database that persists on disk. A specially crafted Lua script executing in Redis can trigger a heap overflow in the cjson library, and result with heap corruption and potentially remote code execution. The problem exists in all versions of Redis with Lua scripting support, starting from 2.6, and affects only authenticated and authorized users. The problem is fixed in versions 7.0.12, 6.2.13, and 6.0.20.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

redis redis

  • >= 7.0.0, < 7.0.12affected
  • >= 6.2.0, < 6.2.13affected
  • >= 6.0.0, < 6.0.20affected

References