Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2022-24775

Improper Input Validation in guzzlehttp/psr7

Description

guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

guzzle psr7

  • < 1.8.4affected
  • >= 2.0.0, < 2.1.1affected

References