Skip to content
CVE PROGRAM SOURCE RECORD6.1 Medium

CVE-2022-23515

Improper neutralization of data URIs may allow XSS in Loofah

Description

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

flavorjones loofah

  • >= 2.1.0, < 2.19.1affected

References