Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2022-23503

TYPO3 vulnerable to Arbitrary Code Execution via Form Framework

Description

TYPO3 is an open source PHP based web content management system. Versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are vulnerable to Code Injection. Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it is possible to inject code instructions to be processed and executed via TypoScript as PHP code. The existence of individual TypoScript instructions for a particular form item and a valid backend user account with access to the form module are needed to exploit this vulnerability. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

TYPO3 typo3

  • >= 8.0.0, < 8.7.49affected
  • >= 9.0.0, < 9.5.38affected
  • >= 10.0.0, < 10.4.33affected
  • >= 11.0.0, < 11.5.20affected
  • >= 12.0.0, < 12.1.1affected

References