Skip to content
CVE PROGRAM SOURCE RECORD8.1 High

CVE-2021-40331

Permissions problem in the Apache Ranger Hive Plugin

Description

An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Ranger Hive Plugin

Default version status: unaffected

  • 2.0.0 to ≤ 2.3.0affected

References