Skip to content
CVE PROGRAM SOURCE RECORDUnscored

CVE-2021-38153

Timing Attack Vulnerability for Apache Kafka Connect and Clients

Description

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Kafka

  • Apache Kafka 2.0.x to ≤ 2.0.1affected
  • Apache Kafka 2.1.x to ≤ 2.1.1affected
  • Apache Kafka 2.2.x to ≤ 2.2.2affected
  • Apache Kafka 2.3.x to ≤ 2.3.1affected
  • Apache Kafka 2.4.x to ≤ 2.4.1affected
  • Apache Kafka 2.5.x to ≤ 2.5.1affected
  • Apache Kafka 2.6.x to ≤ 2.6.2affected
  • Apache Kafka 2.7.x to ≤ 2.7.1affected
  • Apache Kafka 2.8.x to ≤ 2.8.0affected

References