Skip to content
CVE PROGRAM SOURCE RECORD3.5 Low

CVE-2021-3619

Rapid7 Velociraptor Notebooks Authenticated Persistent XSS

Description

Rapid7 Velociraptor 0.5.9 and prior is vulnerable to a post-authentication persistent cross-site scripting (XSS) issue, where an authenticated user could abuse MIME filetype sniffing to embed executable code on a malicious upload. This issue was fixed in version 0.6.0. Note that login rights to Velociraptor is nearly always reserved for trusted and verified users with IT security backgrounds.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Rapid7 Velociraptor

  • 0.5.9 to ≤ 0.5.9affected

References