Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2021-32626

Lua scripts can overflow the heap-based Lua stack in Redis

Description

Redis is an open source, in-memory database that persists on disk. In affected versions specially crafted Lua scripts executing in Redis can cause the heap-based Lua stack to be overflowed, due to incomplete checks for this condition. This can result with heap corruption and potentially remote code execution. This problem exists in all versions of Redis with Lua scripting support, starting from 2.6. The problem is fixed in versions 6.2.6, 6.0.16 and 5.0.14. For users unable to update an additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

redis redis

  • >= 6.2.0, < 6.2.6affected
  • >= 6.0.0, < 6.0.16affected
  • >= 2.6.0, < 5.0.14affected

References