Skip to content
CVE PROGRAM SOURCE RECORD7.1 High

CVE-2021-29447

WordPress Authenticated XXE attack when installation is running PHP 8

Description

Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

WordPress wordpress-develop

  • >= 5.6.0, < 5.7.1affected

References