Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2021-22552

Memory overread secure enclave in Asylo 0.6.2

Description

An untrusted memory read vulnerability in Asylo versions up to 0.6.1 allows an untrusted attacker to pass a syscall number in MessageReader that is then used by sysno() and can bypass validation. This can allow the attacker to read memory from within the secure enclave. We recommend updating to Asylo 0.6.3 or past https://github.com/google/asylo/commit/90d7619e9dd99bcdb6cd28c7649d741d254d9a1a

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Google LLC Asylo

  • unspecified to ≤ 0.6.2affected

References